WordPress版本和PHP版本对应关系列表

WordPress是一个开源的内容管理系统,它是使用PHP语言编写的。因此,它的运行环境必须支持PHP。同时,WordPress也需要依赖于MySQL数据库来存储和管理网站数据。

file

WordPress官方推荐的PHP版本是7.4或更高版本。这是因为PHP 7.4是一个稳定的版本,同时也提供了更好的性能和安全性。如果您使用的是旧版本的PHP,那么升级到7.4或更高版本是非常有必要的。

WordPress的目标是在PHP的新版本发布当天尽可能多地支持它们。作为一个项目,支持这些新版本的过程是在每个新的PHP版本都达到功能冻结并标记测试版之后开始的。这可以防止在计划的功能被删除或实现发生变化时不得不恢复或对WordPress进行额外更改。

过去对支持的PHP版本所做的更改如下:

  • 在WordPress版本4.1中:增加了对PHP 5.6的支持。
  • 在WordPress 4.4中:添加了对PHP 7.0的支持
  • 在WordPress 4.7中:添加了对PHP 7.1的支持。
  • 在WordPress 4.9中:添加了对PHP 7.2的支持。
  • 在WordPress 5.0中:添加了对PHP 7.3的支持
  • 在WordPress 5.2中:放弃了对PHP 5.2、5.3、5.4、5.5的支持。
  • 在WordPress 5.3中:添加了对PHP 7.4的支持(
  • 在WordPress 5.6中:添加了对PHP 8.0的“测试版支持”
  • 在WordPress 5.9中:添加了对PHP 8.1的“测试版支持”
  • 在WordPress 6.1中:添加了对PHP 8.2的“测试版支持”。

详细的版本支持参考下表:

file

具体参考链接:这里

WordPress和PHP版本的支持非常重要,因为它们直接影响着网站的性能和安全性。如果您使用的是WordPress网站,那么及时升级到最新版本的WordPress和PHP是非常必要的。同时,也要注意定期备份网站数据,以防止意外情况的发生。

Supervisor执行Bash管道操作残留子进程
SSH的10个实用用例(强烈推荐)

发表我的评论

电子邮件地址不会被公开。 必填项已用*标注

61 + 98 =

ajax-loader