PHP Composer如何安装?

PHP ComposerPHP的依赖管理工具,用于增加、管理和升级项目中的库依赖。在进行PHP项目开发的时候都需要使用Composer,所以掌握PHP的安装是很重要。

PHP Composer

系统要求

  • PHP版本5.3.2或以上
  • 支持Windows, macOS和Linux平台

PHP Composer

下载Composer

你可以从Composer官网或是通过以下链接进行下载:

安装Composer

  • Windows:运行下载的Composer-Setup.exe并按照提示安装。
  • macOS/Linux:在终端运行以下命令:
  1. 下载安装脚本 php -r "copy('https://getcomposer.org/installer', 'composer-setup.php');"
  2. 检查安装脚本的签名(可选) php -r "if (hash_file('sha384', 'composer-setup.php') === '544e09ee996cdf60ece3804abc52599c22b1f40f4323403c44d44fdfdd586475ca9813a858088ffbc1f233e9b180f061') { echo 'Installer verified'; } else { echo 'Installer corrupt'; unlink('composer-setup.php'); } echo PHP_EOL;"
  3. 运行安装脚本 php composer-setup.php
  4. 删除安装脚本 php -r "unlink('composer-setup.php');"
  5. 全局安装 Composer:
    • 在 Windows 上,将 composer.phar 放置在 PATH 环境变量中的一个目录下。
    • 在 macOS 或 Linux 上,你可以将 composer.phar 移动到 /usr/local/bin(或其他在 PATH 中的目录)以使其全局可用:
      mv composer.phar /usr/local/bin/composer

完成以上步骤后,你已经在你的系统上成功地安装了Composer。

配置Composer

创建一个composer.json文件在你的项目根目录下,并添加下面的代码:

{
    "require": {
        "vendor/package": "1.3.2"
    }
}

vendor/package1.3.2是您需要依赖的库及其版本。

使用 Composer

你可以通过以下命令来安装依赖:

composer install

Composer配置国内源

  • 阿里云 Composer 镜像
    composer config -g repo.packagist composer https://mirrors.aliyun.com/composer/
  • 腾讯云镜像
    composer config -g repo.packagist composer https://mirrors.cloud.tencent.com/composer/
解决php中json_decode的异常JSON_ERROR_CTRL_CHAR ETB控制符
MacOS上Missing xcrun的问题
标签:

发表我的评论

电子邮件地址不会被公开。 必填项已用*标注

67 + 93 =

ajax-loader